Ubuntu下如何将 PostgreSQL 从 9.3 升级到 9.4

Rails
2015-11-06 19:11

开发机上装的是 PostgreSQL 9.3(以下简称pg),新装的日志跟踪 gem 需要 pg 9.4

参考 stackoverflow1, 升级了pg。

首先备份,导出原来的数据库

卸载原来的 pg 9.3

sudo apt-fast remove postgresql postgresql-contrib

Ubuntu 14.04 LTS下没有 pg 9.4的源,先建源

sudo nano /etc/apt/sources.list.d/pgdg.list
# 加入
deb http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main

导入密钥

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -

升级源列表并安装 pg 9.4

sudo apt-fast update && sudo apt-fast -y install postgresql-9.4

导入备份的数据库

All done!

加载 Disqus 评论

© 版权所有 悟理 2013-2019
Powered By Jekyll & Semantic UI

Ubuntu下如何将 PostgreSQL 从 9.3 升级到 9.4

Rails
2015-11-06 19:11

开发机上装的是 PostgreSQL 9.3(以下简称pg),新装的日志跟踪 gem 需要 pg 9.4

参考 stackoverflow1, 升级了pg。

首先备份,导出原来的数据库

卸载原来的 pg 9.3

sudo apt-fast remove postgresql postgresql-contrib

Ubuntu 14.04 LTS下没有 pg 9.4的源,先建源

sudo nano /etc/apt/sources.list.d/pgdg.list
# 加入
deb http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main

导入密钥

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -

升级源列表并安装 pg 9.4

sudo apt-fast update && sudo apt-fast -y install postgresql-9.4

导入备份的数据库

All done!

加载 Disqus 评论

© 版权所有 悟理 2013-2019
Powered By Jekyll & Semantic UI

Ubuntu下如何将 PostgreSQL 从 9.3 升级到 9.4

Rails
2015-11-06 19:11

开发机上装的是 PostgreSQL 9.3(以下简称pg),新装的日志跟踪 gem 需要 pg 9.4

参考 stackoverflow1, 升级了pg。

首先备份,导出原来的数据库

卸载原来的 pg 9.3

sudo apt-fast remove postgresql postgresql-contrib

Ubuntu 14.04 LTS下没有 pg 9.4的源,先建源

sudo nano /etc/apt/sources.list.d/pgdg.list
# 加入
deb http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main

导入密钥

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -

升级源列表并安装 pg 9.4

sudo apt-fast update && sudo apt-fast -y install postgresql-9.4

导入备份的数据库

All done!

加载 Disqus 评论

© 版权所有 悟理 2013-2019
Powered By Jekyll & Semantic UI